
  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.northcentralpa.com/content/tncms/live/" />
<meta name="keywords" content="covid-19_updates, politics, state, life, news" />
<meta name="news_keywords" content="covid-19_updates, politics, state, life, news" />
<meta name="description" content="Harrisburg -- Governor Tom Wolf and Secretary of State Kathy Boockvar provided an update today on the June 2 primary election and outlined how Pennsylvanians can apply for a mail-in" />
<meta name="author" content="NCPA Staff" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="google-site-verification" content="bE94LuAfFuwo0IYqurVQPX21BnciKXh1mNQJuXvdt-g" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.northcentralpa.com/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=1200%2C628" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="628" />
<meta property="og:title" content="June 2 primary election approaches, residents urged to apply for mail-in ballot" />
<meta property="og:description" content="Harrisburg -- Governor Tom Wolf and Secretary of State Kathy Boockvar provided an update today on the June 2 primary election and outlined how Pennsylvanians can apply for a mail-in" />
<meta property="og:site_name" content="NorthcentralPA.com" />
<meta property="og:section" content="Covid-19 Updates" />
<meta property="fb:app_id" content="1422330304504288" />
<meta property="article:publisher" content="http://www.facebook.com/NorthcentralPa" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@northcentralpa" />
<meta name="twitter:image:alt" content="VoterRegistrationDeadline_2020.jpg" />
<meta property="tncms:ads" content="smart,lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.4afa87871b5c74c45e5da67666c2705b.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.93ba289b1a2aa847633520d7a43d11ed.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"pattern","style":"default","path":"\/life\/covid-19_updates","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"NCPA Staff","id":"e682cc58-8e38-11ea-a528-97d57490ab29","app":"editorial"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":266},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-1401564-42"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="//tags.crwdcntrl.net/c/14502/cc.js?ns=_cc14502" id="LOTCC_14502"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc14502.add('tp', 'TNNW');
		_cc14502.add('act', ' User Login');
		_cc14502.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc14502.add('med', 'flag: featured');
	_cc14502.bcp();
</script>

<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.caf244e2614d000b4f73058e1c610d12.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["covid-19_updates","politics","state","life","news"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/northcentralpa.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.36770bdfae09a8898776cd45ffd261f5.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/northcentralpa.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/northcentralpa.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.562ac43ab5c59b0f315e3f7aabdfac51.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/northcentralpa.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/northcentralpa.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/northcentralpa.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/northcentralpa.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/northcentralpa.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            
                gptAdSlots['ad-824531'] = googletag.defineSlot(adUnit, [2, 1], 'ad-824531').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-824531'].setTargeting('pos', ['impact-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            
                gptAdSlots['ad-781851'] = googletag.defineSlot(adUnit, [120, 50], 'ad-781851').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-781851'].setTargeting('pos', ['weather-ad']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], []).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-898176'] = googletag.defineSlot(adUnit, [[320,50]], 'ad-898176').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-898176'].setTargeting('pos', ['leaderboard-mobile-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[728, 90], [320, 50]]).addSize([992, 0], [728, 90]).addSize([1200, 0], [[728, 90], [970, 90]]).build();
                gptAdSlots['ad-824512'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90]], 'ad-824512').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-824512'].setTargeting('pos', ['leaderboard-top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300, 250],[336,280]]).addSize([1200, 0], [[300, 250],[336,280]]).build();
                gptAdSlots['ad-824516'] = googletag.defineSlot(adUnit, [[300,250],[336,280]], 'ad-824516').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-824516'].setTargeting('pos', ['rectangle-1']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320, 50], [300, 250],[336,280]]).addSize([768, 0], [[300, 250],[336,280]]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-827885'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[336,280]], 'ad-827885').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-827885'].setTargeting('pos', ['rectangle-3']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300, 250],[336,280]]).addSize([1200, 0], [[300, 250],[336,280]]).build();
                gptAdSlots['ad-783556'] = googletag.defineSlot(adUnit, [[300,250],[336,280]], 'ad-783556').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-783556'].setTargeting('pos', ['rectangle-2']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300, 250],[336,280]]).addSize([1200, 0], [[300, 250],[336,280]]).build();
                gptAdSlots['ad-829280'] = googletag.defineSlot(adUnit, [[300,250],[336,280]], 'ad-829280').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-829280'].setTargeting('pos', ['rectangle-3']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300, 250],[336,280]]).addSize([1200, 0], [[300, 250],[336,280]]).build();
                gptAdSlots['ad-824521'] = googletag.defineSlot(adUnit, [[300,250],[336,280]], 'ad-824521').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-824521'].setTargeting('pos', ['rectangle-3']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"bg_color":"#D7EAE9","heading_tag":"h4","signup_lists_only":"1","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","text_color":"inherit","list_ids":"","sign_up_text":"Sign up","manage_button_text":"Manage your lists","show_audience":"","hide_audience":"","block_id":"780780"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[728, 90], [320, 50]]).addSize([992, 0], [[728, 90], [970, 90], [970,250]]).addSize([1200, 0], [[728, 90], [970, 90], [970,250]]).build();
                gptAdSlots['ad-824522'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[970,250]], 'ad-824522').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-824522'].setTargeting('pos', ['leaderboard-bottom']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"content_text":"Would you like to receive our daily local newsletter? Sign up today!","display_again":"24","display_triggers":"exit_intent","enable_email":"1","headline_text":"The Latest COVID-19 News in Your Email","list_ids":"5d8add06-4a15-11e7-b96a-4fafefbd25d5","overlay_action":"left","require_user_account":"","sticker_icon":"envelope","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","card_shape":"rounded_rectangle","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon_color":"white","image_display":"medium","lead_in":"","lead_text_color":"dark","lead_text_shadow":"disabled","headline_size":"medium","headline_text_color":"dark","headline_shadow":"disabled","content_text_color":"dark","content_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","button_text":"","button_url":"","button_style":"default","button_size":" ","signup_lists_only":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","display_timer":"","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","utm_campaign_name":"utm_campaign_name","show_audience":"","hide_audience":"","block_id":"784366"}); /*]]>*/</script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"content_text":"Would you like to receive our daily local newsletter? Sign up today!","display_again":"24","display_triggers":"exit_intent","enable_email":"1","headline_text":"The Latest COVID-19 News in Your Email","list_ids":"5d8add06-4a15-11e7-b96a-4fafefbd25d5","overlay_action":"left","require_user_account":"","sticker_icon":"envelope","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","card_shape":"rounded_rectangle","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon_color":"white","image_display":"medium","lead_in":"","lead_text_color":"dark","lead_text_shadow":"disabled","headline_size":"medium","headline_text_color":"dark","headline_shadow":"disabled","content_text_color":"dark","content_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","button_text":"","button_url":"","button_style":"default","button_size":" ","signup_lists_only":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","display_timer":"","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","utm_campaign_name":"utm_campaign_name","show_audience":"","hide_audience":"","block_id":"784366"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/northcentralpa.com/life/covid-19_updates';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [728, 90]).addSize([992, 0], [728, 90]).addSize([1200, 0], [[728, 90], [970, 50], [970, 90]]).build();
                gptAdSlots['ad-815344'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,50],[970,90]], 'ad-815344').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-815344'].setTargeting('pos', ['sticky-anchor']);
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>June 2 primary election approaches, residents urged to apply for mail-in ballot | Covid-19 Updates | northcentralpa.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #000; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #000; } .fixed-nav #main-navigation { background-color: #000 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer { background-color: #efefef; color: #333333; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #fff; } .navbar-toggle .icon-bar { background-color: #fff !important; } .navbar-toggle .sr-only-show { color: #fff !important; } #site-top-nav .list-inline>li>a { color: #000; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header { background-color: #ffffff; }/* remove full span bgs */ #site-navbar-container, #site-header-container, #site-top-nav-container { background-color: transparent !important; background-image: none !important; }/* remove full span bgs */ #site-footer-container { background-color: transparent !important; background-image: none !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #fff; } }#site-copyright a, #site-footer a { color: #000; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #009648; }#site-header{ border-bottom: 3px solid #009648; }#site-footer{ border-top: 3px solid #009648; } .tnt-bg-accent { background-color: #009648; } a .tnt-caret-down { color: #009648; } .block-title .block-title-inner { border-color: #009648; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #009648; } .form-control:focus { border-bottom-color: #009648; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ /* Site Styles */ body {font-family:"Roboto"!important;} .progress-bar {background-color:#528100;} #masthead-col-two .ad-placeholder{margin-bottom:0 !important} .fixed-leaderboard-top .tnt-ads{margin-bottom:0 !important} #tncms-region-ads-fixed-leaderboard-top .tnt-ads{margin-bottom:15px !important} #masthead-col-one {width:55%} #masthead-col-two {width: 20%;margin-top:16px} #masthead-col-three {width:25%;margin-top:15px} #site-header {border:0} #site-header .tnt-ads{margin-bottom:0 !important} #topbar-col-one {font-weight: bold;font-family: 'Opens Sans',sans-serif} .header-search{max-width: 150px} .header-search .site-search-label {font-weight: 600;padding-left:10px} .header-search .tnt-search{font-size:21px} .header-search .dropdown-toggle{padding:5px 10px;border-radius:5px;cursor: pointer;border:0px solid #fff !important} .header-search {margin-left:0px} .header-search .dropdown-menu{left:0;right:auto !important;width:385px;padding:3px} .header-search .dropdown-menu .btn{border-radius:5px !important} #topbar-col-two{width:420px;float: right} .header-user .not-logged-in {margin-top:4px} .weather-current .dropdown-menu {right:0 !important;left: auto !important} /* Header */ .offcanvas-drawer {background-color:#000;} #site-navbar-container {background-color:#ffffff;} #site-navbar-container.affix {background-color:rgba(0,0,0,0);} #main-nav_menu > li > a { padding-left:18px;padding-right:18px;text-transform:uppercase;font-family:'Open Sans', sans-serif} @media (min-width: 992px) and (max-width: 1200px){#main-nav_menu > li > a {font-size:13px !important;padding-left:11px !important ;padding-right:11px !important } } #main-nav_menu > li > a:hover {background-color:#ffffff;color:#000} #main-nav_menu .dropdown-menu{padding-top:0;padding-bottom:0;font-family:'Open Sans', sans-serif;font-weight:400} /* Body */ .block-title {border-bottom:1px solid #efefef; margin:0 0 10px; } .block-title-inner {border-bottom:2px solid #6eb088!important; padding:0!important;} .block-title-inner * {color:#009648 !important; font-family:"Open Sans", sans-serif; text-transform:uppercase;font-weight:bold} .card-headline * {font-family:"Lora", serif; color:#000;} .pos-top li a{font-weight: 600;color:#6eb088;font-size:15px;text-decoration: none} .pos-top {margin-top:2px !important;} .pos-top li a .tnt-svg{color:#ccc;font-size:12px} .pos-top li a:hover .tnt-svg{color:#999} /* @screen-xs----------- */ @media (max-width: 480px) { .pos-top li a{font-weight: normal;font-size:12px} } /* @screen-sm */ @media (min-width: 480px) and (max-width: 991px){ .pos-top li a{font-weight: 600;font-size:13px} } /* Media Queries */ @media (min-width:992px) and (max-width:1199px) { } .carousel-navigation {padding-bottom:50px;} .headlineslider-558392.headlineslider-grid .card-container {max-height:none!important; height:445px!important;} .headlineslider-558392.headlineslider-grid .card-container img {max-height:none!important; min-height:450px; margin:0 auto; width:auto!important; min-width:100%; max-width:none!important;} .event-date-square{background:#323A45 !important} #site-footer {border:0} #site-footer ul{list-style: square;color:#3F6184;font-weight: bold} #site-footer .tnt-section-home .tnt-svg{display: none} #site-footer .tnt-section-home .nav-label{display: inline-block} #site-copyright .col-md-5{text-align: right} .asset .asset-body a{color:#009639} .pa-weather-alert .card{border:0} .pa-weather-alert .tnt-slider-controls{top:0 !important} .highlight-grey .block-title-inner{background:#ccc} .title-no-margin section{margin-bottom:0px !important} .block-no-margin section{margin-bottom:0px !important} .title-no-margin .block-title{margin-bottom:10px} .title-no-margin .block{margin-bottom:0 !important} .hide-business .business-cards{display:none} .hide-headline .card-headline{display:none !important} /* RT: #773369: Blox design question on story pages */ /* Desktops and laptops ----------- */ @media only screen and (min-width: 1224px) { .news-tip-btn { position: relative; top: 178px; left: 314px; z-index: 10001; margin-bottom: 20px; } .staff-directory-btn { position: relative; display: inline-block; top: 88px; left: 153px; z-index: 10000; } } /* Large screens ----------- */ @media only screen and (min-width: 1824px) { .news-tip-btn { position: relative; top: 178px; left: 314px; z-index: 5; margin-bottom: 20px; } .staff-directory-btn { position: relative; display: inline-block; top: 88px; left: 153px; z-index: 4; } } .center-img div {text-align:center;} .center-img img {margin-left: auto; margin-right:auto;} </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.northcentralpa.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/bd627318-87be-11e9-a7e9-270f5962725a.jpg?crop=18%2C18%2C48%2C0&resize=180%2C180&order=crop%2Cresize" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="June 2 primary election approaches, residents urged to apply for mail-in ballot | Covid-19 Updates | northcentralpa.com" href="http://www.northcentralpa.com/search/?f=rss&amp;t=article&amp;c=life/covid-19_updates&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.northcentralpa.com/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html" />
            
    <script defer src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
             
<link href="https://fonts.googleapis.com/css?family=Lora|Roboto|Open+Sans" rel="stylesheet">


<!-- Facebook Pixel Code jsandy #646174-->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window, document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '331501530663231');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=331501530663231&ev=PageView&noscript=1" target="_blank"
/></noscript>
<!-- End Facebook Pixel Code -->

<script language="javascript" type="text/javascript">
    $(document).ready(function() {     
         //$('#site-search-780839-btn ').html('<i class="fas tnt-search" aria-hidden="true"></i>');
         $('.pos-top li a').append(' <i class="fas tnt-arrow-circle-right" aria-hidden="true"></i>');
         $('.header-search .dropdown-toggle').append(' <span class="site-search-label" aria-hidden="true">Find an Article</span>'); 
       
     }); 
    </script>
    
    



        </head>
        <body class="fixed-scroll-nav app-editorial grid-pattern blox-asset uuid-e682cc58-8e38-11ea-a528-97d57490ab29 section-lifesection-covid-19-updates type-article infinity-disabled" data-authors='[]' data-path="/life/covid-19_updates">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.northcentralpa.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=pattern&tncms.page.style=default&tncms.page.path=%2Flife%2Fcovid-19_updates&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=NCPA+Staff&tncms.asset.id=e682cc58-8e38-11ea-a528-97d57490ab29&tncms.asset.app=editorial&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.system.render_time=266&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.google.ua=UA-1401564-42&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-edit-container-e682cc58-8e38-11ea-a528-97d57490ab29" class="asset-owner-content asset-edit-container progress hidden-print">
            <div class="progress-bar progress-bar-primary progress-bar-striped">
                <div class="asset-edit-icon pull-left hidden-sm hidden-xs"><i class="fas tnt-certificate"></i></div>
                <div class="asset-edit-message pull-left">You are the owner of this article.</div>
                <div class="asset-edit-btns pull-right">
                    <a class="btn btn-primary" href="https://www.northcentralpa.com/users/admin/contribute/article/?assetid=e682cc58-8e38-11ea-a528-97d57490ab29&assettype=article"><i class="fas tnt-pen-square"></i> Edit Article</a>
                    
                        <a class="btn btn-danger" href="https://www.northcentralpa.com/users/admin/contribute/article/?from_section=/life/covid-19_updates"><i class="fas tnt-plus-square"></i> Add New Article</a>
                    
                </div>
                <div class="clearfix"></div>
            </div>
        </div>

    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-780844" class="tncms-block hidden-md hidden-lg"><div id="user-controls-780844" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.northcentralpa.com/users/signup/?referer_url=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.northcentralpa.com/users/login/?referer_url=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.northcentralpa.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-780844').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.northcentralpa.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.northcentralpa.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.northcentralpa.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-780844').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.northcentralpa.com/users/logout/" id="user-logout-form-780844"><input type="hidden" name="referer_url" value="https://www.northcentralpa.com/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="/site/forms/online_services/submit_news"  class="nav-link tnt-section-submit-news">Submit News</a>
                                </li><li>
                                    <a href="/newsletters/"  class="nav-link tnt-section-newsletter">Newsletter</a>
                                </li><li>
                                    <a href="/site/employment.html"  class="nav-link tnt-section-employment">Employment</a>
                                </li><li>
                                    <a href="/site/advertise.html"  class="nav-link tnt-section-advertise">Advertise</a>
                                </li><li>
                                    <a href="/site/terms.html"  class="nav-link tnt-section-terms-of-use">Terms of Use</a>
                                </li><li>
                                    <a href="/site/privacy.html"  class="nav-link tnt-section-privacy-policy">Privacy Policy</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/news/crime/"  class="nav-link tnt-section-crime">Crime</a>
                                </li><li>
                                    <a href="/news/roads/"  class="nav-link tnt-section-roads-and-traffic">Roads and Traffic</a>
                                </li><li>
                                    <a href="/news/weather-alerts/"  class="nav-link tnt-section-weather-alerts">Weather Alerts</a>
                                </li><li>
                                    <a href="/news/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a href="/news/state"  class="nav-link tnt-section-state">State</a>
                                </li><li>
                                    <a href="/news/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a href="/news/economy/"  class="nav-link tnt-section-economy">Economy</a>
                                </li><li>
                                    <a href="/news/international/"  class="nav-link tnt-section-international">International</a>
                                </li><li>
                                    <a href="/news/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                                </li><li>
                                    <a href="/life/covid-19_updates/"  class="nav-link tnt-section-covid-19-news-and-updates">COVID-19 News and Updates</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/community/announcements/"  class="nav-link tnt-section-announcements">Announcements</a>
                                </li><li>
                                    <a href="/community/non-profit/"  class="nav-link tnt-section-non-profit">Non-Profit</a>
                                </li><li>
                                    <a href="/community/faith/"  class="nav-link tnt-section-faith">Faith</a>
                                </li><li>
                                    <a href="/community/5k/"  class="nav-link tnt-section-5k">5k</a>
                                </li><li>
                                    <a href="/community/best_of/best_of_northcentral_pa.html"  class="nav-link tnt-section-best-of">Best Of</a>
                                </li><li>
                                    <a href="/community/yard-sale/"  class="nav-link tnt-section-yard-sale">Yard Sale</a>
                                </li><li>
                                    <a href="https://www.northcentralpa.com/community/covid-19_event_updates/covid-19_event_updates.html"  target="_blank" rel="noopener" class="nav-link tnt-section-covid-19-event-updates">COVID 19 Event Updates</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/life/"  class="nav-link tnt-section-life">Life</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/life/announcements/"  class="nav-link tnt-section-announcements">Announcements</a>
                                </li><li>
                                    <a href="/life/arts/"  class="nav-link tnt-section-arts">Arts</a>
                                </li><li>
                                    <a href="/life/covid-19_local_resources/"  class="nav-link tnt-section-covid-19-local-resources">COVID-19 Local Resources</a>
                                </li><li>
                                    <a href="/life/covid-19_public_information/"  class="nav-link tnt-section-covid-19-public-information">COVID-19 Public Information</a>
                                </li><li>
                                    <a href="/life/craft/"  class="nav-link tnt-section-craft">Craft</a>
                                </li><li>
                                    <a href="/life/entertainment/"  class="nav-link tnt-section-entertainment">Entertainment</a>
                                </li><li>
                                    <a href="/life/food/"  class="nav-link tnt-section-food">Food</a>
                                </li><li>
                                    <a href="/life/giveaways/"  class="nav-link tnt-section-giveaways">Giveaways</a>
                                </li><li>
                                    <a href="/life/health/"  class="nav-link tnt-section-health">Health</a>
                                </li><li>
                                    <a href="/life/music/"  class="nav-link tnt-section-music">Music</a>
                                </li><li>
                                    <a href="/life/nightlife/"  class="nav-link tnt-section-nightlife">Nightlife</a>
                                </li><li>
                                    <a href="/life/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                                </li><li>
                                    <a href="/life/wellness/"  class="nav-link tnt-section-wellness">Wellness</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/politics"  class="nav-link tnt-section-politics">Politics</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/politics/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a href="/politics/state/"  class="nav-link tnt-section-state">State</a>
                                </li><li>
                                    <a href="/politics/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a href="/politics/presidential/"  class="nav-link tnt-section-presidential">Presidential</a>
                                </li><li>
                                    <a href="/politics/congress/"  class="nav-link tnt-section-us-congress">US Congress</a>
                                </li><li>
                                    <a href="/politics/senate/"  class="nav-link tnt-section-us-senate">US Senate</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a href="/sports/national"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a href="/sports/crosscutters/"  class="nav-link tnt-section-crosscutters">Crosscutters</a>
                                </li><li>
                                    <a href="/sports/little_league_baseball_world_series/"  class="nav-link tnt-section-llws">LLWS</a>
                                </li><li>
                                    <a href="/sports/high_school_football/"  class="nav-link tnt-section-high-school-football">High School Football</a>
                                </li><li>
                                    <a href="/sports/college_football/"  class="nav-link tnt-section-college-football">College Football</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/features/"  class="nav-link tnt-section-features">Features</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="/features/on-the-pulse/"  class="nav-link tnt-section-on-the-pulse">On-the-pulse</a>
                                </li><li>
                                    <a href="/features/coal-cracker-kitchen/"  class="nav-link tnt-section-coal-cracker-kitchen">Coal Cracker Kitchen</a>
                                </li><li>
                                    <a href="/features/senior-showcase/"  class="nav-link tnt-section-senior-showcases">Senior Showcases</a>
                                </li><li>
                                    <a href="/features/stream-gauge/"  class="nav-link tnt-section-stream-gauge">Stream Gauge </a>
                                </li><li>
                                    <a href="/features/videos/"  class="nav-link tnt-section-videos">Videos</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-9" data-target="#mobile-nav-right_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/business/"  class="nav-link tnt-section-business">Business</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/business/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a href="/business/finance/"  class="nav-link tnt-section-finance">Finance</a>
                                </li><li>
                                    <a href="/business/national"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a href="/business/technology/"  class="nav-link tnt-section-technology">Technology</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-10" data-target="#mobile-nav-right_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/education/"  class="nav-link tnt-section-education">Education</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a href="/education/high-school/"  class="nav-link tnt-section-high-school">High School</a>
                                </li><li>
                                    <a href="/education/college/"  class="nav-link tnt-section-college">College</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries"  class="nav-link tnt-section-obits">Obits</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-12" data-target="#mobile-nav-right_menu-child-12">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="https://www.northcentralpa.com/site/regions.html"  target="_blank" rel="noopener" class="nav-link tnt-section-regions">Regions</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-12" class="collapse nav navbar-nav"><li>
                                    <a href="/regions/bradford/"  class="nav-link tnt-section-bradford">Bradford</a>
                                </li><li>
                                    <a href="/regions/centre/"  class="nav-link tnt-section-centre">Centre</a>
                                </li><li>
                                    <a href="/regions/clinton/"  class="nav-link tnt-section-clinton">Clinton</a>
                                </li><li>
                                    <a href="/regions/columbia/"  class="nav-link tnt-section-columbia">Columbia</a>
                                </li><li>
                                    <a href="/regions/lycoming/"  class="nav-link tnt-section-lycoming">Lycoming</a>
                                </li><li>
                                    <a href="/regions/montour/"  class="nav-link tnt-section-montour">Montour</a>
                                </li><li>
                                    <a href="/regions/northumberland/"  class="nav-link tnt-section-northumberland">Northumberland</a>
                                </li><li>
                                    <a href="/regions/potter/"  class="nav-link tnt-section-potter">Potter</a>
                                </li><li>
                                    <a href="/regions/snyder/"  class="nav-link tnt-section-snyder">Snyder</a>
                                </li><li>
                                    <a href="/regions/sullivan/"  class="nav-link tnt-section-sullivan">Sullivan</a>
                                </li><li>
                                    <a href="/regions/tioga/"  class="nav-link tnt-section-tioga">Tioga</a>
                                </li><li>
                                    <a href="/regions/union/"  class="nav-link tnt-section-union">Union</a>
                                </li></ul></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-780843" class="tncms-block hidden-md hidden-lg"><section id="block-780843" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-780843" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-780843" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-780843-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-780843-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-780843-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-780843').submit();
        return false;
    });

    $('#site-search-780843').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-780843 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-780843 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-780843-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-824531" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-824531" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-824531');
                        
                });
            </script>
        </div>
    </div>
</div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise-with-us"  href="/site/advertise.html" >
                    <span class="nav-label">Advertise with Us</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-780839" class="tncms-block pull-left header-search"><ul id="site-search-780839-dropdown" class="hidden-print nav navbar-nav navbar-right site-search-full">
        <li class="search-form-dropdown dropdown yamm-fw">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-780839" action="/search/" method="GET" class="yamm-content">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal ">
        <input id="site-search-780839-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-780839-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-780839-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-780839').submit();
        return false;
    });

    $('#site-search-780839').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-780839 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-780839 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-780839-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-780846" class="tncms-block header-user padding-right"><div id="user-controls-780846" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" class="user-control-link" rel="nofollow">
                        <span class="fas tnt-user"></span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a role="menuitem" class="btn btn-block btn-primary" href="https://www.northcentralpa.com/users/login/?referer_url=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a role="menuitem" href="https://www.northcentralpa.com/users/signup/?referer_url=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.northcentralpa.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.northcentralpa.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.northcentralpa.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-780846').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.northcentralpa.com/users/logout/" id="user-logout-form-780846"><input type="hidden" name="referer_url" value="https://www.northcentralpa.com/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-780845" class="tncms-block"><div class="follow-links-780845 pull-right">
    
    <section id="block-780845" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://www.facebook.com/NorthcentralPa" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/northcentralpa" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/northcentralpa" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.instagram.com/northcentralpa" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.northcentralpa.com",
  "sameAs" : ["http://www.facebook.com/NorthcentralPa","https://twitter.com/northcentralpa","https://www.youtube.com/northcentralpa","https://www.instagram.com/northcentralpa"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-810126" class="tncms-block a"><section id="block-810126" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/30ad5c78-c8d0-11e9-a347-cbfde4ce61df.png?resize=200%2C21 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/30ad5c78-c8d0-11e9-a347-cbfde4ce61df.png?resize=300%2C32 300w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/30ad5c78-c8d0-11e9-a347-cbfde4ce61df.png?resize=400%2C42 400w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/30ad5c78-c8d0-11e9-a347-cbfde4ce61df.png?resize=540%2C57 540w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/30ad5c78-c8d0-11e9-a347-cbfde4ce61df.png?resize=750%2C79 750w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/30ad5c78-c8d0-11e9-a347-cbfde4ce61df.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-780840" class="tncms-block"><div id="weather-780840" class="weather-current size-large pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=17701" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-cloudy"></span>
                </span>
                <span class="pull-left temp-desc large">
                    <span class="temp">55&deg;</span>
                    
                        <span class="cond">Mostly Cloudy <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="17701"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-780840 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Williamsport, PA
                                
                                 <small>(17701)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Some clouds. Low 38F. Winds NW at 10 to 20 mph..</p>
                            <h5>Tonight</h5>
                            <p>Some clouds. Low 38F. Winds NW at 10 to 20 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: May 4, 2020 @ 5:50 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=17701"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-781851" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-781851" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-781851');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-780837" class="tncms-block"><section id="block-780837" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/e0701500-bf5d-11e9-a8d1-f703fe986a7a.png?resize=200%2C32 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/e0701500-bf5d-11e9-a8d1-f703fe986a7a.png?resize=300%2C48 300w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/e0701500-bf5d-11e9-a8d1-f703fe986a7a.png?resize=400%2C64 400w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/e0701500-bf5d-11e9-a8d1-f703fe986a7a.png?resize=540%2C86 540w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/e0701500-bf5d-11e9-a8d1-f703fe986a7a.png?resize=750%2C119 750w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/e0701500-bf5d-11e9-a8d1-f703fe986a7a.png?resize=1200%2C191 1200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/e0701500-bf5d-11e9-a8d1-f703fe986a7a.png?resize=1700%2C270 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-news"  href="/site/forms/online_services/submit_news" >
                    <span class="nav-label">Submit News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newsletter"  href="/newsletters/" >
                    <span class="nav-label">Newsletter</span>
                </a></li><li>
                <a class="nav-link  tnt-section-employment"  href="/site/employment.html" >
                    <span class="nav-label">Employment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise"  href="/site/advertise.html" >
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link  tnt-section-terms-of-use"  href="/site/terms.html" >
                    <span class="nav-label">Terms of Use</span>
                </a></li><li>
                <a class="nav-link  tnt-section-privacy-policy"  href="/site/privacy.html" >
                    <span class="nav-label">Privacy Policy</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-crime"  href="/news/crime/" >
                    <span class="nav-label">Crime</span>
                </a></li><li>
                <a class="nav-link  tnt-section-roads-and-traffic"  href="/news/roads/" >
                    <span class="nav-label">Roads and Traffic</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather-alerts"  href="/news/weather-alerts/" >
                    <span class="nav-label">Weather Alerts</span>
                </a></li><li>
                <a class="nav-link  tnt-section-local"  href="/news/local/" >
                    <span class="nav-label">Local</span>
                </a></li><li>
                <a class="nav-link  tnt-section-state"  href="/news/state" >
                    <span class="nav-label">State</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national"  href="/news/national/" >
                    <span class="nav-label">National</span>
                </a></li><li>
                <a class="nav-link  tnt-section-economy"  href="/news/economy/" >
                    <span class="nav-label">Economy</span>
                </a></li><li>
                <a class="nav-link  tnt-section-international"  href="/news/international/" >
                    <span class="nav-label">International</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/news/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-covid-19-news-and-updates"  href="/life/covid-19_updates/" >
                    <span class="nav-label">COVID-19 News and Updates</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/community/" >
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-announcements"  href="/community/announcements/" >
                    <span class="nav-label">Announcements</span>
                </a></li><li>
                <a class="nav-link  tnt-section-non-profit"  href="/community/non-profit/" >
                    <span class="nav-label">Non-Profit</span>
                </a></li><li>
                <a class="nav-link  tnt-section-faith"  href="/community/faith/" >
                    <span class="nav-label">Faith</span>
                </a></li><li>
                <a class="nav-link  tnt-section-5k"  href="/community/5k/" >
                    <span class="nav-label">5k</span>
                </a></li><li>
                <a class="nav-link  tnt-section-best-of"  href="/community/best_of/best_of_northcentral_pa.html" >
                    <span class="nav-label">Best Of</span>
                </a></li><li>
                <a class="nav-link  tnt-section-yard-sale"  href="/community/yard-sale/" >
                    <span class="nav-label">Yard Sale</span>
                </a></li><li>
                <a class="nav-link  tnt-section-covid-19-event-updates"  href="https://www.northcentralpa.com/community/covid-19_event_updates/covid-19_event_updates.html"  target="_blank" rel="noopener">
                    <span class="nav-label">COVID 19 Event Updates</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-life"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/life/" >
                    <span class="nav-label">Life</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-announcements"  href="/life/announcements/" >
                    <span class="nav-label">Announcements</span>
                </a></li><li>
                <a class="nav-link  tnt-section-arts"  href="/life/arts/" >
                    <span class="nav-label">Arts</span>
                </a></li><li>
                <a class="nav-link  tnt-section-covid-19-local-resources"  href="/life/covid-19_local_resources/" >
                    <span class="nav-label">COVID-19 Local Resources</span>
                </a></li><li>
                <a class="nav-link  tnt-section-covid-19-public-information"  href="/life/covid-19_public_information/" >
                    <span class="nav-label">COVID-19 Public Information</span>
                </a></li><li>
                <a class="nav-link  tnt-section-craft"  href="/life/craft/" >
                    <span class="nav-label">Craft</span>
                </a></li><li>
                <a class="nav-link  tnt-section-entertainment"  href="/life/entertainment/" >
                    <span class="nav-label">Entertainment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-food"  href="/life/food/" >
                    <span class="nav-label">Food</span>
                </a></li><li>
                <a class="nav-link  tnt-section-giveaways"  href="/life/giveaways/" >
                    <span class="nav-label">Giveaways</span>
                </a></li><li>
                <a class="nav-link  tnt-section-health"  href="/life/health/" >
                    <span class="nav-label">Health</span>
                </a></li><li>
                <a class="nav-link  tnt-section-music"  href="/life/music/" >
                    <span class="nav-label">Music</span>
                </a></li><li>
                <a class="nav-link  tnt-section-nightlife"  href="/life/nightlife/" >
                    <span class="nav-label">Nightlife</span>
                </a></li><li>
                <a class="nav-link  tnt-section-outdoors"  href="/life/outdoors/" >
                    <span class="nav-label">Outdoors</span>
                </a></li><li>
                <a class="nav-link  tnt-section-wellness"  href="/life/wellness/" >
                    <span class="nav-label">Wellness</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-politics"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/politics" >
                    <span class="nav-label">Politics</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local"  href="/politics/local/" >
                    <span class="nav-label">Local</span>
                </a></li><li>
                <a class="nav-link  tnt-section-state"  href="/politics/state/" >
                    <span class="nav-label">State</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national"  href="/politics/national/" >
                    <span class="nav-label">National</span>
                </a></li><li>
                <a class="nav-link  tnt-section-presidential"  href="/politics/presidential/" >
                    <span class="nav-label">Presidential</span>
                </a></li><li>
                <a class="nav-link  tnt-section-us-congress"  href="/politics/congress/" >
                    <span class="nav-label">US Congress</span>
                </a></li><li>
                <a class="nav-link  tnt-section-us-senate"  href="/politics/senate/" >
                    <span class="nav-label">US Senate</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local"  href="/sports/local/" >
                    <span class="nav-label">Local</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national"  href="/sports/national" >
                    <span class="nav-label">National</span>
                </a></li><li>
                <a class="nav-link  tnt-section-crosscutters"  href="/sports/crosscutters/" >
                    <span class="nav-label">Crosscutters</span>
                </a></li><li>
                <a class="nav-link  tnt-section-llws"  href="/sports/little_league_baseball_world_series/" >
                    <span class="nav-label">LLWS</span>
                </a></li><li>
                <a class="nav-link  tnt-section-high-school-football"  href="/sports/high_school_football/" >
                    <span class="nav-label">High School Football</span>
                </a></li><li>
                <a class="nav-link  tnt-section-college-football"  href="/sports/college_football/" >
                    <span class="nav-label">College Football</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-features"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/features/" >
                    <span class="nav-label">Features</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-on-the-pulse"  href="/features/on-the-pulse/" >
                    <span class="nav-label">On-the-pulse</span>
                </a></li><li>
                <a class="nav-link  tnt-section-coal-cracker-kitchen"  href="/features/coal-cracker-kitchen/" >
                    <span class="nav-label">Coal Cracker Kitchen</span>
                </a></li><li>
                <a class="nav-link  tnt-section-senior-showcases"  href="/features/senior-showcase/" >
                    <span class="nav-label">Senior Showcases</span>
                </a></li><li>
                <a class="nav-link  tnt-section-stream-gauge"  href="/features/stream-gauge/" >
                    <span class="nav-label">Stream Gauge </span>
                </a></li><li>
                <a class="nav-link  tnt-section-videos"  href="/features/videos/" >
                    <span class="nav-label">Videos</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-business"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/business/" >
                    <span class="nav-label">Business</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local"  href="/business/local/" >
                    <span class="nav-label">Local</span>
                </a></li><li>
                <a class="nav-link  tnt-section-finance"  href="/business/finance/" >
                    <span class="nav-label">Finance</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national"  href="/business/national" >
                    <span class="nav-label">National</span>
                </a></li><li>
                <a class="nav-link  tnt-section-technology"  href="/business/technology/" >
                    <span class="nav-label">Technology</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-education"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/education/" >
                    <span class="nav-label">Education</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-high-school"  href="/education/high-school/" >
                    <span class="nav-label">High School</span>
                </a></li><li>
                <a class="nav-link  tnt-section-college"  href="/education/college/" >
                    <span class="nav-label">College</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-obits"  href="/obituaries" >
                    <span class="nav-label">Obits</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-regions"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="https://www.northcentralpa.com/site/regions.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Regions</span>
                </a><ul id="main-nav_menu-child-12" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-bradford"  href="/regions/bradford/" >
                    <span class="nav-label">Bradford</span>
                </a></li><li>
                <a class="nav-link  tnt-section-centre"  href="/regions/centre/" >
                    <span class="nav-label">Centre</span>
                </a></li><li>
                <a class="nav-link  tnt-section-clinton"  href="/regions/clinton/" >
                    <span class="nav-label">Clinton</span>
                </a></li><li>
                <a class="nav-link  tnt-section-columbia"  href="/regions/columbia/" >
                    <span class="nav-label">Columbia</span>
                </a></li><li>
                <a class="nav-link  tnt-section-lycoming"  href="/regions/lycoming/" >
                    <span class="nav-label">Lycoming</span>
                </a></li><li>
                <a class="nav-link  tnt-section-montour"  href="/regions/montour/" >
                    <span class="nav-label">Montour</span>
                </a></li><li>
                <a class="nav-link  tnt-section-northumberland"  href="/regions/northumberland/" >
                    <span class="nav-label">Northumberland</span>
                </a></li><li>
                <a class="nav-link  tnt-section-potter"  href="/regions/potter/" >
                    <span class="nav-label">Potter</span>
                </a></li><li>
                <a class="nav-link  tnt-section-snyder"  href="/regions/snyder/" >
                    <span class="nav-label">Snyder</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sullivan"  href="/regions/sullivan/" >
                    <span class="nav-label">Sullivan</span>
                </a></li><li>
                <a class="nav-link  tnt-section-tioga"  href="/regions/tioga/" >
                    <span class="nav-label">Tioga</span>
                </a></li><li>
                <a class="nav-link  tnt-section-union"  href="/regions/union/" >
                    <span class="nav-label">Union</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-884386" class="tncms-block visible-md visible-lg"><section id="block-884386" class="block emphasis-h3   " ><div class="block">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/710298c4-685d-11ea-a39f-c77b60553801.jpg?resize=200%2C8 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/710298c4-685d-11ea-a39f-c77b60553801.jpg?resize=300%2C12 300w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/710298c4-685d-11ea-a39f-c77b60553801.jpg?resize=400%2C16 400w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/710298c4-685d-11ea-a39f-c77b60553801.jpg?resize=540%2C22 540w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/710298c4-685d-11ea-a39f-c77b60553801.jpg?resize=750%2C31 750w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/710298c4-685d-11ea-a39f-c77b60553801.jpg?resize=1200%2C49 1200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/710298c4-685d-11ea-a39f-c77b60553801.jpg 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="COVID-19 Coverage"></div></section></div><div id="tncms-block-884370" class="tncms-block col-md-3 col-sm-6 center-img"><section id="block-884370" class="block emphasis-h3   " ><div class="block"><a href="/life/covid-19_updates/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/8fa2b54a-685b-11ea-a39f-4bfd1410fb09.jpg?resize=200%2C112 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/8fa2b54a-685b-11ea-a39f-4bfd1410fb09.jpg 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="COVID-19 News &amp; Updates"></a></div></section></div><div id="tncms-block-884379" class="tncms-block col-md-3 col-sm-6 center-img"><section id="block-884379" class="block emphasis-h3   " ><div class="block"><a href="/community/covid-19_event_updates/covid-19_event_updates.html" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/c87b3cd8-685c-11ea-a39f-c393283627d1.jpg?resize=200%2C112 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/c87b3cd8-685c-11ea-a39f-c393283627d1.jpg 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="COVID-19 Schedules &amp; Events"></a></div></section></div><div id="tncms-block-898176" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-898176" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-898176');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-884381" class="tncms-block col-md-3 col-sm-6 center-img"><section id="block-884381" class="block emphasis-h3   " ><div class="block"><a href="/life/covid-19_local_resources/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/fab46a9e-685c-11ea-a39f-1f631757fba8.jpg?resize=200%2C112 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/fab46a9e-685c-11ea-a39f-1f631757fba8.jpg 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="COVID-19 Local Resources"></a></div></section></div><div id="tncms-block-884382" class="tncms-block col-md-3 col-sm-6 center-img"><section id="block-884382" class="block emphasis-h3   " ><div class="block"><a href="/life/covid-19_public_information/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/1c6a96a4-685d-11ea-a39f-fb077fe21302.jpg?resize=200%2C112 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/1c6a96a4-685d-11ea-a39f-fb077fe21302.jpg 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="COVID-19 Public Information"></a></div></section></div><div id="tncms-block-824512" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-824512" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-824512');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div><div id="modal-image-f589da16-8e38-11ea-8d21-03810749002b" class="modal fullscreen in modal-image image-default modal-f589da16-8e38-11ea-8d21-03810749002b" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=400%2C209"
                    srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=200%2C105 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=300%2C157 300w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=400%2C209 400w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=540%2C283 540w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=750%2C393 750w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=1200%2C628 1200w"
                    sizes="100vw"
                    width="1200"
                    height="628"
                    alt="VoterRegistrationDeadline_2020.jpg"
                    class="img-responsive true-size" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-f589da16-8e38-11ea-8d21-03810749002b" data-target=".caption-inner-modal-image-f589da16-8e38-11ea-8d21-03810749002b">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-f589da16-8e38-11ea-8d21-03810749002b collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.northcentralpa.com%2Fvoterregistrationdeadline-2020-jpg%2Fimage_f589da16-8e38-11ea-8d21-03810749002b.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/voterregistrationdeadline-2020-jpg/image_f589da16-8e38-11ea-8d21-03810749002b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f589da16-8e38-11ea-8d21-03810749002b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=VoterRegistrationDeadline_2020.jpg&via=northcentralpa&url=https%3A%2F%2Fwww.northcentralpa.com%2Fvoterregistrationdeadline-2020-jpg%2Fimage_f589da16-8e38-11ea-8d21-03810749002b.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/voterregistrationdeadline-2020-jpg/image_f589da16-8e38-11ea-8d21-03810749002b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f589da16-8e38-11ea-8d21-03810749002b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.northcentralpa.com/voterregistrationdeadline-2020-jpg/image_f589da16-8e38-11ea-8d21-03810749002b.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/voterregistrationdeadline-2020-jpg/image_f589da16-8e38-11ea-8d21-03810749002b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f589da16-8e38-11ea-8d21-03810749002b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.northcentralpa.com/tncms/asset/editorial/f589da16-8e38-11ea-8d21-03810749002b" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f589da16-8e38-11ea-8d21-03810749002b"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BNorthcentralPA.com%5D%20VoterRegistrationDeadline_2020.jpg&body=https%3A%2F%2Fwww.northcentralpa.com%2Fvoterregistrationdeadline-2020-jpg%2Fimage_f589da16-8e38-11ea-8d21-03810749002b.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f589da16-8e38-11ea-8d21-03810749002b"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/voterregistrationdeadline-2020-jpg/image_f589da16-8e38-11ea-8d21-03810749002b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f589da16-8e38-11ea-8d21-03810749002b"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-f589da16-8e38-11ea-8d21-03810749002b-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="f589da16-8e38-11ea-8d21-03810749002b" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="f589da16-8e38-11ea-8d21-03810749002b" class="save-list-f589da16-8e38-11ea-8d21-03810749002b-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="f589da16-8e38-11ea-8d21-03810749002b" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-f589da16-8e38-11ea-8d21-03810749002b img { max-height: 628px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-e682cc58-8e38-11ea-a528-97d57490ab29" class="asset article-default"  data-url="https://www.northcentralpa.com/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=1200%2C628">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="628">
        </div>
        <meta itemprop="name" content="northcentralpa.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.northcentralpa.com/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html" />
    <style>
                .asset-paging .direction {
                    color: #009648;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.northcentralpa.com\/tncms\/search\/mlt\/?origin=e682cc58-8e38-11ea-a528-97d57490ab29&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-e682cc58-8e38-11ea-a528-97d57490ab29" class="asset-paging">
                <div id="paging-prev-e682cc58-8e38-11ea-a528-97d57490ab29" class="paging-link prev offset"></div>
                <div id="paging-next-e682cc58-8e38-11ea-a528-97d57490ab29" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
        <div class="asset-label-flags">
            <span class="tnt-flag label label-flag label-flag-default label-flag-featured">featured</span> 
        </div>
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            June 2 primary election approaches, residents urged to apply for mail-in ballot
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-ef176220-e51e-11e9-9f13-4f00f0e3ea9b-asset-e682cc58-8e38-11ea-a528-97d57490ab29" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.northcentralpa.com/users/profile/NCPA%20Staff">NCPA Staff</a></span>
                
                    <div id="author-popup-ef176220-e51e-11e9-9f13-4f00f0e3ea9b-asset-e682cc58-8e38-11ea-a528-97d57490ab29-content" class="hide">
                        <article class="clearfix card author popup-content card-author-ef176220-e51e-11e9-9f13-4f00f0e3ea9b">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.northcentralpa.com/users/profile/NCPA%20Staff" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="NCPA Staff"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/avatars/e/f1/762/ef176220-e51e-11e9-9f13-4f00f0e3ea9b.dcd935c4ce64a1eca21d45143a556279.png?_dc=1579207032"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.northcentralpa.com/users/profile/NCPA%20Staff" rel="author" class="tnt-user-profile-link tnt-user-name">NCPA Staff</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:news@northcentralpa.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-ef176220-e51e-11e9-9f13-4f00f0e3ea9b-asset-e682cc58-8e38-11ea-a528-97d57490ab29').popover({
                            content: $('#author-popup-ef176220-e51e-11e9-9f13-4f00f0e3ea9b-asset-e682cc58-8e38-11ea-a528-97d57490ab29-content').html(),
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2020-05-04T17:30:00-04:00" class="tnt-date asset-date text-muted">
            May 4, 2020
        </time>
    </li>
            <li class="hidden-print">
        <time datetime="2020-05-04T17:30:00-04:00" class="tnt-date asset-date text-muted">35 min ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-05-04T17:30:00-04:00">
    <meta itemprop="datePublished" content="2020-05-04T17:30:00-04:00">
    <meta itemprop="dateModified" content="2020-05-04T17:30:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=June%202%20primary%20election%20approaches%2C%20residents%20urged%20to%20apply%20for%20mail-in%20ballot&via=northcentralpa&url=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.northcentralpa.com/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.northcentralpa.com/tncms/asset/editorial/e682cc58-8e38-11ea-a528-97d57490ab29" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BNorthcentralPA.com%5D%20June%202%20primary%20election%20approaches%2C%20residents%20urged%20to%20apply%20for%20mail-in%20ballot&body=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-f589da16-8e38-11ea-8d21-03810749002b" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-f589da16-8e38-11ea-8d21-03810749002b" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="628">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=1200%2C628">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=1200%2C628">
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=400%2C209"
                    srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=200%2C105 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=300%2C157 300w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=400%2C209 400w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=540%2C283 540w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=750%2C393 750w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/f/58/f589da16-8e38-11ea-8d21-03810749002b/5eb0655baad6b.image.jpg?resize=1200%2C628 1200w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), 100vw"
                    width="1200"
                    height="628"
                    alt="VoterRegistrationDeadline_2020.jpg"
                    class="img-responsive full tnt-restrict-img-f589da16-8e38-11ea-8d21-03810749002b" />
            </div><style>
                .tnt-restrict-img-f589da16-8e38-11ea-8d21-03810749002b {
                    max-width: 1200px;
                }
            </style>
                
                
            </div>
            
                
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="e682cc58-8e38-11ea-a528-97d57490ab29" data-smart-adunit="/132916964/northcentralpa.com/life/covid-19_updates">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=June%202%20primary%20election%20approaches%2C%20residents%20urged%20to%20apply%20for%20mail-in%20ballot&via=northcentralpa&url=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.northcentralpa.com/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.northcentralpa.com/tncms/asset/editorial/e682cc58-8e38-11ea-a528-97d57490ab29" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BNorthcentralPA.com%5D%20June%202%20primary%20election%20approaches%2C%20residents%20urged%20to%20apply%20for%20mail-in%20ballot&body=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-e682cc58-8e38-11ea-a528-97d57490ab29-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="e682cc58-8e38-11ea-a528-97d57490ab29" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="e682cc58-8e38-11ea-a528-97d57490ab29" class="save-list-e682cc58-8e38-11ea-a528-97d57490ab29-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="e682cc58-8e38-11ea-a528-97d57490ab29" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p><span>Harrisburg -- Governor Tom Wolf and Secretary of State Kathy Boockvar provided an update today on the June 2 primary election and outlined how Pennsylvanians can apply for a mail-in ballot.</span></p><p><span>The deadline to apply is 5 p.m. on May 26. "Apply as soon as possible," the Governor urged. He said he will be applying today. Go to <a href="http://VotesPA.com">VotesPA.com</a>.</span></p><p><span>"Polling places will still be open, although where you vote may change," said Gov. Wolf. He reminded residents to watch their county election offices for location.</span></p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p><span>The state says they are doing everything possible to protect the public who do choose to vote in person on June 2. Masks will be distributed at polling places. Floor tape will mark safe social distance positions, and kits including santizer and sanitizing wipes will be provided at polling places. Exercise social distance practices, wear masks, and exercise your right to vote. </span></p><p><span><span>"We are in an unprecedented time and are facing a major public health crisis in a presidential election year," said Governor Wolf. "I want Pennsylvanians to know that they have options for how to cast their ballots, including both voting by mail and voting in person. Voting is the cornerstone of our democracy, and Pennsylvanians can still cast their ballots while keeping themselves safe and healthy."</span></span></p><p><span>Secretary of State Kathy Boockvar praised the foresight in the passing of <a href="https://www.votespa.com/About-Elections/Pages/Voting-Reforms.aspx" target="_blank">Act 77</a>, allowing Pennsylvanians more voting options. "Thank goodness one of those options was vote by mail," she said, "at the time they had no idea how important that would be."</span></p><p><span>The state has taken measures to be prepared for June 2, including launching a comprehensive voter education campaign to alert residents of the new date and availability of online option, and a b</span>ilingual public awareness campaign via TV, radio, and digital channels.</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-780741" class="tncms-block"><section id="block-780741" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-780741 ">
        <div class="block-title-inner">
            <h3>
                
                More from this section
                
            </h3>
        </div>
    </div></div><div class="card-grid   card-img-md card-compact">
        
        
            <div class=" row">
        
        <div class=" col-sm-4 last-grid-item">
                 
                                
                    <article id="card-summary-780741-26d89e22-a35e-546e-8729-408f76506e6c" class="clearfix card summary has-image image-top inherit  tnt-section-news tnt-sub-section-state">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-26d89e22-a35e-546e-8729-408f76506e6c media-preview article-asset" data-aspect="4:3"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/state/area-lawmakers-respond-to-restrictions/article_26d89e22-a35e-546e-8729-408f76506e6c.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Area lawmakers respond to restrictions"
                            class="img-responsive lazyload full"
                            width="539"
                            height="404"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/9/13/913f7eab-ea8b-5d33-b697-8885b88a7240/5eaef0ba9ab3f.image.jpg?crop=539%2C404%2C50%2C0&resize=200%2C150&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/9/13/913f7eab-ea8b-5d33-b697-8885b88a7240/5eaef0ba9ab3f.image.jpg?crop=539%2C404%2C50%2C0&resize=300%2C225&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/9/13/913f7eab-ea8b-5d33-b697-8885b88a7240/5eaef0ba9ab3f.image.jpg?crop=539%2C404%2C50%2C0&resize=400%2C300&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/9/13/913f7eab-ea8b-5d33-b697-8885b88a7240/5eaef0ba9ab3f.image.jpg?crop=539%2C404%2C50%2C0&resize=539%2C404&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/state/area-lawmakers-respond-to-restrictions/article_26d89e22-a35e-546e-8729-408f76506e6c.html" class="tnt-asset-link">
        

        
            Area lawmakers respond to restrictions</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        
        <div class="clearfix hidden-xs"></div>
        
        
        </div>
        </div></section></div></div><p>The education campaigns have worked, Boockvar said. "Over 960,000 applications have already been submitted, 76% of those done online." </p><p><span>Schools and other facilities are urged to work with counties for expanded polling places. Schools, in fact, can be mandated to open. Private facilities may be strongly urged to serve as polling places, but not mandated. </span></p><p><span>The state received $14 million from the CARES act for COVID-19 related expenses, and an additional $15 million, Boockvar said, from previous funding sources. Of these funds, $13 million will be distributed to individual counties for increaseed staff, equipment, supplies, mailers, and other communication costs.</span></p><p><span>The National Guard have been key members of the COVID-19 mitigation effort. If the National Guard is called in to help during elections, they'll be serving in plain clothes, Boockvar said.</span></p><p>"We will vote in a secure and safe fashion."</p><p>Additional resources:</p><ul><li><span>Check your voter status at </span><a href="http://votespa.com/Status?fbclid=IwAR06kQnrqber0EpHcZsGOOEOOzIPQdBFc0nKETuSKpQueD1jnZan6SpnezM" rel="noopener nofollow" target="_blank" data-ft="{" data-lynx-mode="async" data-lynx-uri="https://l.facebook.com/l.php?u=http%3A%2F%2FVotesPA.com%2FStatus%3Ffbclid%3DIwAR06kQnrqber0EpHcZsGOOEOOzIPQdBFc0nKETuSKpQueD1jnZan6SpnezM&amp;h=AT3R1XznYtH9g0dZuL4n1Bs-nCZJaOioxrrdFHld4gUea1CUQ5QGn099gYYLGP7ZiqtsW-d8AKC87J3-RpUABrXMHs2SsIZptsOSJzanu-OqJTwcqz2zAY4ReadaychH7NI_DQp_5Ghyx9_Dq5cCXfoQ4IYs9qkqHRyU1MoeD0RVs2JDBbBmJmf1m33En7qlzYVIiyYFEs55-pml6HsduKRF64WE8L0MaF4wJXnJhJ7oikJlSbRTHj_OiRAoKgL5Q4axhoUDw-Bi9ItGBwrwrEqDIeCQSCuK2vezCN7rdo7fZZB-_CwE_ahGco0B0j6VH7SLt5-qCtVOcpcQRuMpu3Im9NiT2dzSO8yjvqVpUZNvtEWX6FVmkZznA2iJvUw1vKpR0r6vfrNAR1IsoVls68sv5M5mvN_anKdI24JdsAa--NrrKQ-Zox_IM5HeHXjf96O1KOv5JmQeXtB6IDNQjZjEEfqjQGbWpM8C8oc9Ra5yxWiXIUhUeotovwbKZdH92tJNcg3o3LV5nC_QZ9QJNSaJ5NdvnlBZqxGbazN6kG1el8ZK47hYzhTL8-l105cnEA89hxDjrWuWW3Dh6Hz8jUaNV_Vz-UZz9B3dwtnf5MsJYgoLFaRY-RrhLKlJpm8cCWJv93XaMsQVR4Eq8l4">VotesPA.com/Status</a><span>.</span></li><li><span>Register or update your registration at </span><a href="http://register.votespa.com/?fbclid=IwAR2qZUflBl_XYONugBsUqBOCDQYwt0BEysAb6Z25zCUBzmB6qGpH4T_EO48" rel="noopener nofollow" target="_blank" data-ft="{" data-lynx-mode="async" data-lynx-uri="https://l.facebook.com/l.php?u=http%3A%2F%2FRegister.VotesPA.com%2F%3Ffbclid%3DIwAR2qZUflBl_XYONugBsUqBOCDQYwt0BEysAb6Z25zCUBzmB6qGpH4T_EO48&amp;h=AT2oUAOsm_EgLg4XpKH1hDY-raPWh8jbrIWCE0RcvLu4S3BTUkLuCxr1QaX5SQsdNkjeZTwosF-Uel_4WYbqSTaLG-I2LvE1An7J4QMpYT4xgxh9x8FHUjubQj8Xk0blDD1g7SOZlKCjIyIYJ6GabFxPl5nWrsP_as5SFJl_r6yLhmyatOCoGGtPNYacsB7Bl1Z_VY2Hiv836Aru22UDyRnppJKPSCw85E2Aqgct8drz39v0BkALrQLdaux2wdsJy9Pw4HIFMkVYCI-pb5IyN_sZYdSxHSti_PkhD1lWqktLmW8iLBJ6NBdOez2mK__er3e23FfOJbogmAAXdAUEuBYF-LGCfRIVWzw8ur__-olloc6nYv7msB3Kb-U3SNWaQa5-BKxrzUrXycd2wQCfMqLx_tThXMEEVdIig9tGRzOzGZ8DbnTVBVQNcFXeZ8AA-dxsXGkuyFLfAxwG_Bby_WSrvEof7s3EPQMzCLN0_W7GbtZhPXfFfAQxbOwDrPCfooxMuMMGXiE5NITzBmyuML-GfoRG3Jpy4xWHCNVywx1pK2FoWrF5dqtSkouFrzYehq2MT5J28gO4ehl_V8dye0_PqK_vl56677feQzcIoXjYkWlGSND78TS609Q0KARTrQ8016sI5hnv7kNlHKc">Register.VotesPA.com.</a></li><li><span>Want to vote by mail? Sign up at </span><a href="http://votespa.com/ApplyMailBallot?fbclid=IwAR2Loh4cguzDxHBM-pcM3fOnGxV6Q5VJcWBuHvnL7VA9YcvnA-PigSDGEiE" rel="noopener nofollow" target="_blank" data-ft="{" data-lynx-mode="async" data-lynx-uri="https://l.facebook.com/l.php?u=http%3A%2F%2FVotesPA.com%2FApplyMailBallot%3Ffbclid%3DIwAR2Loh4cguzDxHBM-pcM3fOnGxV6Q5VJcWBuHvnL7VA9YcvnA-PigSDGEiE&amp;h=AT1zWjBHccxpL4zEtCW-Gjbh_QCLEswD1uwR_nyeMWjPsyAtqkXpOEtq0raWanjNrsKrEQYcpTJ7DIFf7SenMN_tyatB2M7YPvgxIOibZV-alLKC3rEvpMX7kiimpnoiT7hXh0_aFrMMZlLHPZA-cGKBwa0RA0h8pVvKjSBnDH2EKrhUATPviEiPzzSm7UDA29vWLmnTFkUmpIGai8Flz05gVPbIcwjbPLa1W-gePMn26KbS3n-q6c9xPAyItGdnkBBTYSeCUmZxkqXTkHrA0eV_YbgW6xANFPo9FGApipops9q-xSKKid2xD7H3jqLRw5aNWSlUxtyMB2k6HiRREXu8I4Fz_JdvTP1u-QgVb_ARuVxJfmeYGqn6UAxy9CnibX0VDips_nxQV7EW3LOo2HeuoO5XQpNI9JH2XLAA4fJF9iuTKyQYwVUj6WbuA0d0dzWD5_LM3mmcrrQ_IG2mabqAotKJWYxJtE52cmDyttCygMBYpnyIVrQuVaQVw1pm5vyrIJHj2BrVPMNbkKFw2ZxSt4dIWecca2UN-xPk8-SbwWCnD1TxQ8djREC87NnWlYMNYd8kcUTrzWb0EKQ0uGErSUqwdQgdFSjjw7ITBWxtm40fObccMLC8q140PT9x36dG2eEYa8VlBKqfI_8">VotesPA.com/ApplyMailBallot</a><span>.</span></li><li><span>Call 1-877-Votes-PA with questions.</span></li></ul><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"><div id="tncms-block-856521" class="tncms-block"><h3><a href="https://www.northcentralpa.com/site/forms/correction_or_typo">Report a correction or typo</a></h3></div></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"><div id="tncms-block-862242" class="tncms-block news-tip-btn"><section id="block-862242" class="block emphasis-h2   " ><article class="card promo media card-img-md"><figure class="pull-left"><a href="/site/forms/online_services/submit_news/">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/6604b03c-4464-11ea-b117-4bd924ae90bd.jpg" 
                data-sizes="auto" 
                class="img-default img-responsive lazyload tnt-prop-img"
                alt=""></a></figure><div class="media-body"></div>
</article></section></div><div id="tncms-block-862252" class="tncms-block staff-directory-btn"><section id="block-862252" class="block emphasis-h2   " ><article class="card promo media card-img-md"><figure class="pull-left"><a href="/site/staff.html">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/73e20f60-4464-11ea-b117-6787d6b9f850.jpg" 
                data-sizes="auto" 
                class="img-default img-responsive lazyload tnt-prop-img"
                alt=""></a></figure><div class="media-body"></div>
</article></section></div></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=June%202%20primary%20election%20approaches%2C%20residents%20urged%20to%20apply%20for%20mail-in%20ballot&via=northcentralpa&url=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.northcentralpa.com/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.northcentralpa.com/tncms/asset/editorial/e682cc58-8e38-11ea-a528-97d57490ab29" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BNorthcentralPA.com%5D%20June%202%20primary%20election%20approaches%2C%20residents%20urged%20to%20apply%20for%20mail-in%20ballot&body=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/life/covid-19_updates/june-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot/article_e682cc58-8e38-11ea-a528-97d57490ab29.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"e682cc58-8e38-11ea-a528-97d57490ab29"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-e682cc58-8e38-11ea-a528-97d57490ab29-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="e682cc58-8e38-11ea-a528-97d57490ab29" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="e682cc58-8e38-11ea-a528-97d57490ab29" class="save-list-e682cc58-8e38-11ea-a528-97d57490ab29-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="e682cc58-8e38-11ea-a528-97d57490ab29" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-ef176220-e51e-11e9-9f13-4f00f0e3ea9b">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.northcentralpa.com/users/profile/NCPA%20Staff" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="NCPA Staff"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/avatars/e/f1/762/ef176220-e51e-11e9-9f13-4f00f0e3ea9b.dcd935c4ce64a1eca21d45143a556279.png?_dc=1579207032"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.northcentralpa.com/users/profile/NCPA%20Staff" rel="author" class="tnt-user-profile-link tnt-user-name">NCPA Staff</a>
                                </h4>
                                    <p class="card-about">This story was compiled by an NCPA staff reporter from submitted news. To see a list of our editorial staff please visit our staff directory. </p>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:news@northcentralpa.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul><div class="followed-notify-link hidden-print"><button id="follow-author-ef176220-e51e-11e9-9f13-4f00f0e3ea9b" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=ef176220-e51e-11e9-9f13-4f00f0e3ea9b&amp;s=start_time&amp;sd=desc" data-subject="NCPA Staff" data-description="Whenever NCPA Staff posts new content, you'll get an email delivered to your inbox with a link." data-name="NCPA Staff notification" data-author-id="ef176220-e51e-11e9-9f13-4f00f0e3ea9b" data-user-url="https://www.northcentralpa.com/users/">
        <i class="fas tnt-star"></i> Follow NCPA Staff
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" data-tncms-track-dmp='is_followed_notifications_user'>
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.northcentralpa.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.northcentralpa.com/users/login/?referer_url=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.northcentralpa.com/users/signup/?referer_url=https%3A%2F%2Fwww.northcentralpa.com%2Flife%2Fcovid-19_updates%2Fjune-2-primary-election-approaches-residents-urged-to-apply-for-mail-in-ballot%2Farticle_e682cc58-8e38-11ea-a528-97d57490ab29.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-824516" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-824516" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-824516');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-780784" class="tncms-block"><section id="block-780784" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-780784 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-780784" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-780784" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-780784" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-780784" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/life/covid-19_updates/clinton-countys-coronavirus-cases-are-growing-at-the-fastest-rate-in-the-state/article_4db29090-8a5e-11ea-ab6b-f3f50480b7fb.html">Clinton County's coronavirus cases are growing at the fastest rate in the state</a></li><li><a href="/news/crime/three-women-charged-with-alleged-heroin-operation/article_4870dcc4-872d-11ea-94b7-97c0fc0be63b.html">Three women charged with alleged heroin operation</a></li><li><a href="/news/crime/williamsport-parents-accused-of-blowing-marijuana-smoke-at-infant/article_19b186d4-8973-11ea-9b1a-9f2aa94f55ad.html">Williamsport parents accused of blowing marijuana smoke at infant</a></li><li><a href="/life/covid-19_updates/bells-to-chime-throughout-pennsylvania-this-sunday/article_f3485d08-8916-11ea-96f6-af758591830e.html">Bells to chime throughout Pennsylvania this Sunday</a></li><li><a href="/news/crime/man-charged-for-allegedly-threatening-off-duty-trooper-in-union-county/article_b074a626-8a51-11ea-a4eb-731447626242.html">Man charged for allegedly threatening off duty trooper in Union County</a></li><li><a href="/life/covid-19_updates/dept-of-labor-and-industry-employees-who-refuse-to-work-not-eligible-for-unemployment-benefits/article_af450dfa-83d9-11ea-a9e4-3fd1c4a1f543.html">Dept. of Labor and Industry: Employees who refuse to work not eligible for unemployment benefits</a></li><li><a href="/news/muncy-woman-charged-with-theft-after-allegedly-selling-fake-percocet-to-undercover-trooper/article_522f5ed8-8cd8-11ea-a4e3-0f530179bd09.html">Muncy woman charged with theft after allegedly selling fake Percocet to undercover trooper</a></li><li><a href="/news/life-threatening-injuries-caused-by-fentanyl-dui-psp-stonington/article_14e47f40-8cc9-11ea-9d4b-e7679188b064.html">Life-threatening injuries caused by Fentanyl DUI: PSP Stonington</a></li><li><a href="/life/covid-19_public_information/pennsylvania-putting-more-money-in-unemployment-checks-this-week/article_a1dca544-7bbc-11ea-b902-0b12afbddcb8.html">Pennsylvania putting more money in unemployment checks this week</a></li><li><a href="/news/state-police-searching-for-missing-bradford-county-woman/article_6428f800-8900-11ea-9217-f78cde7ca8cf.html">State police searching for missing Bradford County woman</a></li></ul></div>
        
        
            <div id="images-780784" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/angelina-peluso-murder-for-hire-2020/image_33ef8c4a-88cd-11ea-bc47-3328ddb507b3.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Angelina Peluso murder for hire _ 2020"
                            class="img-responsive lazyload full"
                            width="628"
                            height="628"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/3/3e/33ef8c4a-88cd-11ea-bc47-3328ddb507b3/5ea74d8b4fac7.image.jpg?crop=628%2C628%2C286%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/coronaviruszipcodemap-ncpa-jpg/image_9a5bd08a-834e-11ea-8799-7b598aa1b65a.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="coronaviruszipcodemap_NCPA.jpg"
                            class="img-responsive lazyload full"
                            width="628"
                            height="628"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/9/a5/9a5bd08a-834e-11ea-8799-7b598aa1b65a/5e9e1534d2e23.image.jpg?crop=628%2C628%2C286%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/otp-youtube-freevids-2020-jpg/image_43f8d5fc-8967-11ea-97d5-d319964530e0.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="OTP_Youtube_FreeVids_2020.jpg"
                            class="img-responsive lazyload full"
                            width="683"
                            height="683"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/4/3f/43f8d5fc-8967-11ea-97d5-d319964530e0/5ea84f904f6de.image.jpg?crop=683%2C683%2C170%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/curtis-swanger-penndot-jpg/image_766c6c38-8c55-11ea-ae82-3b808ff244db.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="curtis swanger penndot.jpg"
                            class="img-responsive lazyload full"
                            width="628"
                            height="628"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/7/66/766c6c38-8c55-11ea-ae82-3b808ff244db/5ead3a2f7e200.image.jpg?crop=628%2C628%2C286%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/jerry-oleksiak-jpg/image_d8e388a2-8b91-11ea-ab9f-f3edf29cf6f5.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="jerry oleksiak.jpg"
                            class="img-responsive lazyload full"
                            width="628"
                            height="628"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/d/8e/d8e388a2-8b91-11ea-ab9f-f3edf29cf6f5/5eabf1ff56a5b.image.jpg?crop=628%2C628%2C286%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-780784" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/russell-redding-speaks-about-buying-local-dairy/video_328a417a-845d-11ea-865c-0398fe4937c7.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Russell Redding speaks about buying local dairy"
                            class="img-responsive lazyload full"
                            width="1080"
                            height="1080"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/assets/v3/editorial/3/28/328a417a-845d-11ea-865c-0398fe4937c7/5e9fddfd633cc.image.jpg?crop=1080%2C1080%2C420%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
    </div>
</div></section></div><div id="tncms-block-827885" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-827885" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-827885');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-783556" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-783556" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-783556');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-829280" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-829280" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-829280');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-824521" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-824521" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-824521');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-780780" class="tncms-block"><section id="block-780780" class="block emphasis-h4   " ><div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        <div class="mailinglist-container">
                <form
                    id="mailinglist-form-780780"
                    class="mailinglist-form form-validate"
                    action="/tncms/mailinglist/signup/"
                    method="post">
                    <input type="hidden" name="submit" value="1">
                    <div class="form-group mailing-lists ">
                        
                            <div class="mailinglist-item priority-0 checkbox">
                                <label>
                                    <input class="mailinglist-id-780780" type="checkbox" name="list_id[]" value="936eca7a-729b-11ea-8cee-c386c813e4b1" data-name="COVID-19  Update" title="COVID-19  Update" >
                                    <h4 class="mailinglist-title">COVID-19  Update</h4>
                                    
                                        <p>Would you like to receive our daily COVID-19 afternoon update newsletter?&nbsp;<strong>Sign up today!</strong></p>
                                    
                                </label>
                            </div>
                        
                            <div class="mailinglist-item priority-0 checkbox">
                                <label>
                                    <input class="mailinglist-id-780780" type="checkbox" name="list_id[]" value="5d8add06-4a15-11e7-b96a-4fafefbd25d5" data-name="Daily Headlines" title="Daily Headlines" >
                                    <h4 class="mailinglist-title">Daily Headlines</h4>
                                    
                                        <p><span>Would you like to receive our daily local newsletter?&nbsp;</span><strong>Sign up today!</strong></p>
                                    
                                </label>
                            </div>
                        
                        <label class="warning-list hide has-error text-danger" for="list_id[]">You must select at least one email list.</label>
                    </div><div class="form-group  email-address">
                        <div class="input-group">
                            <span class="input-group-addon"><i class="fas tnt-envelope"></i></span>
                            <input id="email-780780" class="form-control email" title="email" name="email" type="email" placeholder="Enter email address">
                        </div>
                        <label class="warning-email hide has-error text-danger" for="email">Please enter a valid email address.</label>
                    </div>
                    <div class="row">
                        <div class="mailinglist-btn-container col-sm-6">
                            <button class="mailinglist-save btn btn-primary btn-block">Sign up<i class="fas tnt-spinner tnt-spin" style="display:none; margin-left:5px;"></i></button>
                        </div>
                        <div class="mailinglist-btn-container col-sm-6">
                            <a class="btn btn-default btn-block" href="https://www.northcentralpa.com/users/admin/mailinglist/">Manage your lists</a>
                        </div>
                    </div>
                </form>
            </div>
        
    </div></div>
        </div></div></section></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-824522" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-824522" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-824522');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-784366" class="tncms-block"><div class="modal promo-designer-modal in left " id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true" >
        <div class="modal-dialog modal-md left">
            <div class="modal-content">
                <div class="modal-body"><section id="block-784366" class="block emphasis-h3   " ><div class="promo-design"><div class="card-bg-color rounded_rectangle">
        <div class="card-panel panel"><button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true" class="fas tnt-times"></span></button>
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                    
                        <div class="headline medium dark ">
                            The Latest COVID-19 News in Your Email
                        </div>
                    
                    
                        <p class="text dark ">
                            Would you like to receive our daily local newsletter? Sign up today!
                        </p>
                    <div class="card email-signup">
                                <div class="alert alert-success" role="alert" style="display:none;">
                                    <p>
                                        <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
                                    </p>
                                </div>
                                <div class="alert alert-danger" role="alert" style="display:none;">
                                    <p>
                                        <strong>Error!</strong> There was an error processing your request.
                                    </p>
                                </div>
                                <div class="mailinglist-container dark  ">
                                        <form
                                            id="mailinglist-form-784366"
                                            class="mailinglist-form form-validate"
                                            action="/tncms/mailinglist/signup/"
                                            method="post">
                                            <input type="hidden" name="submit" value="1">
                                            <div class="form-group mailing-lists ">
                                                
                                                    <div class="mailinglist-item priority-0 ">
                                                        
                                                            <input class="mailinglist-id-784366" type="checkbox" name="list_id[]" value="5d8add06-4a15-11e7-b96a-4fafefbd25d5" data-name="Daily Headlines" style="display:none;" checked>
                                                            <h4 class="mailinglist-title" style="display:none;">Daily Headlines</h4>
                                                            
                                                        
                                                    </div>
                                                
                                                
                                            </div>
                                            <div class="form-group email-address">
                                                <div class="input-group">
                                                    <span class="input-group-addon"><i class="fas tnt-envelope"></i></span>
                                                    <input id="email-784366" class="form-control email" name="email" type="email" placeholder="Enter email address">
                                                </div>
                                                <label class="warning-email hide has-error text-danger" for="email">Please enter a valid email address.</label>
                                            </div>
                                            <div class="row">
                                                <div class="mailinglist-btn-container col-sm-6">
                                                    <button class="mailinglist-save btn btn-block btn-default">Sign up<i class="fas tnt-spinner tnt-spin" style="display:none; margin-left:5px;"></i></button>
                                                </div>
                                                
                                                    <div class="mailinglist-btn-container col-sm-6">
                                                        <a class="btn btn-default btn-block manage" href="https://www.northcentralpa.com/users/admin/mailinglist/">Manage your lists</a>
                                                    </div>
                                                
                                            </div>
                                        </form>
                                    </div>
                                
                            </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section>
    <script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js"> </script><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-780759" class="tncms-block"><section id="block-780759" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-780759 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community"  href="/community/" >
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link  tnt-section-life"  href="/life/" >
                    <span class="nav-label">Life</span>
                </a></li><li>
                <a class="nav-link  tnt-section-politics"  href="/politics" >
                    <span class="nav-label">Politics</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-features"  href="/features/" >
                    <span class="nav-label">Features</span>
                </a></li><li>
                <a class="nav-link  tnt-section-business"  href="/business/" >
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link  tnt-section-education"  href="/education/" >
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obits"  href="/obituaries" >
                    <span class="nav-label">Obits</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="/online_features/" >
                    <span class="nav-label">Online Features</span>
                </a></li><li>
                <a class="nav-link  tnt-section-jobs"  href="/jobs/" >
                    <span class="nav-label">Jobs</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-780762" class="tncms-block"><section id="block-780762" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-780762 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-submission-forms"  href="/site/forms/" >
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newsletter"  href="/newsletters/" >
                    <span class="nav-label">Newsletter</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search-archives"  href="/search/" >
                    <span class="nav-label">Search Archives</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link  tnt-section-corrections-policy"  href="https://www.northcentralpa.com/site/corrections_policy.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Corrections Policy</span>
                </a></li><li>
                <a class="nav-link  tnt-section-ethics-policy"  href="https://www.northcentralpa.com/site/ethics_policy.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Ethics Policy</span>
                </a></li><li>
                <a class="nav-link  tnt-section-fact-checking"  href="https://www.northcentralpa.com/site/fact_checking.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Fact Checking</span>
                </a></li><li>
                <a class="nav-link  tnt-section-ownership"  href="https://www.northcentralpa.com/site/ownership.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Ownership</span>
                </a></li><li>
                <a class="nav-link  tnt-section-staff"  href="https://www.northcentralpa.com/site/staff.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Staff</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-780760" class="tncms-block"><section id="block-780760" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-780760 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>NorthcentralPA.com</strong><br>
    321 Pine Street Suite 220<br>
    Williamsport, PA 17701
    <br>
    
        
        <strong>Email:</strong> <a href="mailto:News@NorthcentralPa.com">News@NorthcentralPa.com</a><br>
    
</address></section></div><div id="tncms-block-856528" class="tncms-block"><h5><a href="https://www.northcentralpa.com/site/forms/correction_or_typo"><b>Report a correction or typo</b></a></h5></div><div id="tncms-block-780761" class="tncms-block padding-bottom"><div class="follow-links-780761 default">
    
    <section id="block-780761" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-780761 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="http://www.facebook.com/NorthcentralPa" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/northcentralpa" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/northcentralpa" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.instagram.com/northcentralpa" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.northcentralpa.com",
  "sameAs" : ["http://www.facebook.com/NorthcentralPa","https://twitter.com/northcentralpa","https://www.youtube.com/northcentralpa","https://www.instagram.com/northcentralpa"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-861731" class="tncms-block"><section id="block-861731" class="block emphasis-h3   " ><div class="block"><a href="www.lionpublishers.com" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/content/tncms/custom/image/605d8766-439d-11ea-930a-376d4cb278be.jpg" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-780763" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-780763"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">NorthcentralPA.com</a>, 321 Pine Street Suite 220 Williamsport, PA</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-815344" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-815344" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" data-mobile-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-815344');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("e682cc58-8e38-11ea-a528-97d57490ab29")});});
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                	_cc14502.add('act', dmpData);
	_cc14502.bcp();

            });
        });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.b419cb3c218ef0da9fa281dd92729a83.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.5dd2f631c0899403c746c644466933ea.js"></script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.d623712c6b7d8bac4ef2995a9297b281.js"></script>
<script>/*<![CDATA[*/ $('.mailing-lists input:checked').each(function(){
        var mailListData = 'is_maillist_subscriber: ' + $(this).val();	_cc14502.add('act', mailListData);
	_cc14502.bcp();
}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/northcentralpa.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.401fb49843570310569f23fe61cfb144.js"></script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        	_cc14502.add('act', dmpData);
	_cc14502.bcp();

                    }
                }
            }
         /*]]>*/</script></body>
</html>